[カテゴリ一覧へ戻る]


回答

標準の設定では SSI は動作いたしません。Apache の設定ファイル httpd.conf を、以下のとおり変更する必要があります。httpd.conf は通常、/etc/httpd/conf/ 以下に存在します。

■設定方法

以下の記述を追記します。

AddOutputFilter INCLUDES .shtml

また、拡張子 .html .htm のファイルで SSI を有効にするためには、追加行の末尾にそれぞれの拡張子を追記します。

AddOutputFilter INCLUDES .shtml .html .htm

 なお httpd.conf の編集後に編集結果を反映させるためには、Apache を再起動する必要があります。
また、この作業自体は弊社の保証範囲外となりますので、予めhttpd.conf の文法チェックなどを踏まえた上でお客様の責任の範囲でご設定ください。

対象サービス
Webmin 搭載・コントロールパネルなしのサーバサービス

Category: Webmin

回答

Web(Apache)サーバではサーバ全体のリソースを確保するため、標準でWebサーバの同時接続数(MaxClients)が設定されております。Webサーバの同時接続数に設定された数値までは、スムーズに閲覧することができます。

しかし、同時接続数を超えるアクセスに対してはタイムアウト設定時間までの間、ブラウザがロード中となり、接続数に空きが出た場合に閲覧可能となり、タイムアウト時間を過ぎた場合には接続ができなくなります。

上記事象が発生した場合は、標準の場合に限り下記ログに出力される場合がございます。

■/var/log/httpd/error_logログ(一部抜粋) ※CentOS6以前:Apache 2.3.13以前の表示
[error] server reached MaxClients setting, consider raising the MaxClients setting

■/var/log/httpd/error_logログ(一部抜粋) ※CentOS7以降:Apache 2.3.13以降の出力例
(preforkモード)
server reached MaxRequestWorkers setting, consider raising the MaxRequestWorkers setting

■解消方法
お客様にて、Webサーバのサービスの再起動をご実施いただくか、弊社サポートまでお問い合わせください。

Webサーバの再起動方法につきましては、下記FAQをご確認ください。

Apache(httpd)の再起動方法を教えてください

回答

クララオンラインで採用している主要なソフトウェアのバージョン(2020年3月現在)は、次のとおりです。基本的にOSが採用しているミドルウェアのバージョンを弊社では基本的にサポートしております。

主なソフトウェアのバージョン

ソフトウェア RHEL 4
CentOS 4
RHEL 5
CentOS 5
RHEL 6
CentOS 6
RHEL 7
CentOS 7
Apache 2.0.52 2.2.3 2.2.15 2.4.6
PHP 4.3.9 5.1.6 5.3.3 5.4.16
MySQL 4.1.22 5.0.77 5.1.73
MariaDB ※1 5.5.64
PostgreSQL 7.4.26 8.1.18 8.4.20 9.2.24
Perl 5.8.5 5.8.8 5.10.1 5.16.3
ImageMagick 6.0.7 6.2.8 6.7.2.7 6.7.8.9
gd ※2 2.0.28 2.0.33 2.0.35 2.0.35
Sendmail 8.13.1 8.13.8 提供無し 提供無し
qmail 1.0.3 1.0.3 提供無し 提供無し
Postfix 2.2.10 2.3.3 2.6.6 2.10.1
BIND bind-9.2.4 bind-9.3.6 bind-9.8.2 bind-9.11.4
openssl 0.9.8e-27.el5_10.3 1.0.1e-58.el6_10 1.0.2k-19.el7

 

情報は、本ページ作成時点のものです。ソフトウェアのバージョンは、予告なく変更される場合がございます。当社では、安定したバージョンのソフトウェアを採用しています。採用バージョンは最新でない場合もございます。

※1 MySQLと互換性をもつデータベースとなります。
      CentOS 7以降の標準データベースが、MySQLから、MariaDBへ変更になりました。
      CentOS 7以降でMySQLをインストールしなければならない場合は、お客様にて作業をご実
  施
いただきますようお願いいたします。
  なお、お客様にてCentOS 7以降でMySQLをインストールされた場合、弊社サポートをおこ
  な
わせていただくことができません。

※2 PHP上で利用できるGDライブラリとは異なります。
      RHEL4 の PHP4.3.9、RHEL5 の PHP5.1.6 に は GIF イメージの読み書き可能な GD 2.0.28
      compatibleがバンドルされています。 RHEL3付属のPHP 4.3.2には GIF イメージは読み取り
      のみ(書き込み不可)の GD 2.0.12 compatibleがバンドルされています。

バージョンの確認方法につきましては、下記FAQをご確認ください。
PHPのバージョンを教えてください。(Plesk環境の場合)

また、コントロールパネルPlesk Onyx 以降をご利用の場合には、追加でPHP7をインストールしていただければ、ドメイン毎にPHPバージョンを選択いただくことができます。
インストール方法は、以下のFAQをご参照ください。

Plesk Onyx でPHP7系を利用したいがどうすればいいか?

※Plesk Onyx以前のバージョンではご利用はできません。
ご利用には、Plesk Onyx 以降を搭載したサーバへのご移行が必要となりますので、移行をご検討をいただきますようお願い致します。

Category: OS

Load More